• 欢迎访问duantianhen的网站,主要总结PHP、Go、服务器、前端、推荐使用最新版火狐浏览器和Chrome浏览器访问本网站

composer遇到PHP版本问题

PHP admin 6个月前 (09-25) 106次浏览 已收录 0个评论

执行composer install 或者composer update时遇到问题如下:

Your requirements could not be resolved to an installable set of packages.
Problem 1
- Installation request for doctrine/instantiator 1.0.3 -> satisfiable by doctrine/instantiator[1.0.3].
- doctrine/instantiator 1.0.3 requires php ~5.3 -> your PHP version (7.0.3) does not satisfy that requirement.
Problem 2
- doctrine/instantiator 1.0.3 requires php ~5.3 -> your PHP version (7.0.3) does not satisfy that requirement.
- phpunit/phpunit-mock-objects 2.3.0 requires doctrine/instantiator ~1.0,>=1.0.1 -> satisfiable by doctrine/instantiator[1.0.3].
- Installation request for phpunit/phpunit-mock-objects 2.3.0 -> satisfiable by phpunit/phpunit-mock-objects[2.3.0].
扩展对应PHP有些问题,这里可以设置composer忽略PHP的版本问题
composer install –ignore-platform-reqs
composer update –ignore-platform-reqs

本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:composer遇到PHP版本问题
喜欢 (0)

您必须 登录 才能发表评论!