• 我们中的有些人,注定要在日常生活的点滴中去寻找生命的意义。---- 《生活大爆炸》|

linux下swoole扩展安装

Linux admin 2年前 (2018-04-08) 424次浏览 已收录 0个评论

【注】windows下不支持该扩展,下为在linux下安装

安装swoole前必须保证系统已经安装了下列软件

php-5.3.10 或更高版本
gcc-4.4 或更高版本
make
autoconf
pcre (centos系统可以执行命令:yum install pcre-devel)

Swoole扩展是按照PHP标准扩展构建的。使用phpize来生成编译检测脚本,./configure来做编译配置检测,make进行编译,make install进行安装。

  1. PECL

    swoole项目已收录到PHP官方扩展库,除了手工下载编译外,还可以通过PHP官方提供的pecl命令,一键下载安装swoole

    pecl install swoole

【注】更多安装细节请看看 官方文档


本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:linux下swoole扩展安装
喜欢 (0)

您必须 登录 才能发表评论!